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About This Manual
This guide tells you how to use P4Merge, the Perforce visual diff tool. It is intended for anyone using
P4Merge to view the differences between files across time and across codelines. P4Merge, as its name
implies, also enables you to merge differing files into one.

Helix documentation
The following table lists and describes key documents for Helix users, developers, and administrators.
For complete information see the following:

http://www.perforce.com/documentation

For specific information about… See this documentation…

Overview of Helix version control concepts
and workflows; Helix architecture, and
related products.

Helix Solutions Overview

Administering the Helix versioning engine
to support git repos and LFS files.

Helix for Git

Using the command-line interface to
perform software version management
and codeline management; working with
Helix streams; jobs, reporting, scripting,
and more.

Helix Versioning Engine User Guide

Basic workflows using P4V, the cross-
platform Helix desktop client.

P4V User Guide

Working with personal and shared
servers and understanding the distributed
versioning features of the Helix Versioning
engine.

Using Helix for Distributed Versioning

p4 command line (reference). P4 Command Reference, p4 help

Installing and administering the Helix
versioning engine, including user
management, security settings.

Helix Versioning Engine Administrator Guide:
Fundamentals

Installing and configuring Helix servers
(proxies, replicas, and edge servers) in a
distributed environment.

Helix Versioning Engine Administrator Guide: Multi-site
Deployment

Helix plug-ins and integrations. IDEs: Using IDE Plug-ins
Defect trackers: Defect Tracking Gateway Guide
Others: online help from the Helix menu or web site

http://www.perforce.com/documentation
http://www.perforce.com/perforce/doc.current/manuals/solutions/index.html
http://www.perforce.com/perforce/doc.current/manuals/helix-for-git/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4guide/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4v/index.html
http://www.perforce.com/perforce/doc.current/manuals/dvcs/index.html
http://www.perforce.com/perforce/doc.current/manuals/cmdref/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dist/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dist/index.html
http://www.perforce.com/perforce/r12.1/manuals/p4plugins/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dtg/index.html
http://www.perforce.com/
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For specific information about… See this documentation…

Developing custom Helix applications
using the Helix C/C++ API.

C/C++ API User Guide

Working with Helix in Ruby, Perl, Python,
and PHP.

APIs for Scripting

Syntax conventions
Helix documentation uses the following syntax conventions to describe command line syntax.

Notation Meaning

literal Monospace font indicates a word or other notation that must be used in
the command exactly as shown.

italics Italics indicate a parameter for which you must supply specific
information. For example, for a serverid parameter, you must supply the id
of the server.

[-f] Square brackets indicate that the enclosed elements are optional. Omit the
brackets when you compose the command.

Elements that are not bracketed are required.

… Ellipses (…) indicate that the preceding element can be repeated as often
as needed.

element1 | element2 A vertical bar ( | ) indicates that either element1 or element2 is required.

Please give us feedback
We are interested in receiving opinions on this manual from our users. In particular, we’d like to hear
from users who have never used Perforce before. Does this guide teach the topic well? Please let us
know what you think; we can be reached at manual@perforce.com.

If you need assistance, or wish to provide feedback about any of our products, contact
support@perforce.com.

http://www.perforce.com/perforce/doc.current/manuals/p4api/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4script/index.html
mailto:manual@perforce.com
mailto:support@perforce.com
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Chapter 1 Diffing and Merging Files with P4Merge
P4Merge is a visual diff tool that displays the differences between file versions and helps you to
resolve conflicts and merge competing versions into one.

This chapter includes the following topics:

• “Diffing Text Files” on page 1

• “Diffing Images” on page 2

• “Diffing Microsoft Word Files” on page 2

• “Merging Files” on page 3

Diffing Text Files
In its diff mode, P4Merge enables you to compare two text files to locate differences. (P4Merge can also
diff image files and, if your Perforce administrator has enabled it, Microsoft Word .docx files.)

The purple icon (  ) is associated with the first file you selected, and purple bands highlight text that
is in the first file but not the second file. The green icon (  ) is associated with the second file you
selected, and green bands highlight text that is in the second file but not the first file.

To display diffs in a single pane, go to View > Single Pane Diff Layout. In single-pane mode, deleted
text is shown using strikethrough text. By default, P4Merge displays diffs in a side-by-side layout.

To toggle the display of line numbers, click  .

Navigate Diffs
To move forward and back through individual differences, or to locate specific text or lines, click the
toolbar buttons listed below.

Go to next/previous diff

Find text

Go to line number

Set Preferences
To configure P4Merge settings to display or suppress differences in white space and line endings,

click  or choose File > Comparison Method. To configure other settings, go to Edit > Preferences
(Windows) or P4Merge > Preferences (Mac).

Note If you are comparing Unicode files, selection of the correct character set is essential.
If you select the wrong character set, P4Merge cannot correctly diff files.
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Diffing Images
To diff two different image files: context-click an image file, choose Diff Against… and specify the
other image, or (in the Depot, Workspace, or Files pane,) drop one image file’s icon on another.

To diff two revisions of the same image file: context-click the image file and choose File History. In
the File History pane, drop one of the desired revisions on the other revision.

P4V launches P4Merge, displaying the differences between the specified images. You can display
image diffs side by side or overlaid.

To enlarge or reduce the displayed images, use the zoom sliders or choose the desired display option
from the View menu.

To highlight differences, check Highlight Differences and use the adjacent slider to increase or
decrease sensitivity. P4Merge highlights identical areas in gray and differences in yellow.

To blend or separate overlaid images, use the vertical slider: to blend the images equally, center the
slider. To increase the amount of an image used in the composite, move the slider toward that image.

You can also view image revisions sequentially in Time-lapse View. For more information, see
Viewing Image File History with Time-lapse View in the P4V User’s Guide.

You can diff the following image file types:

• BMP

• GIF

• JPG, JPEG

• PNG

• PBM

• PGM

• PPM

• TIFF

• XBM

• XPM

Diffing Microsoft Word Files
If your Perforce administrator has enabled it, you can diff Microsoft Word .docx files in a P4Merge
window using a rich comparison tool that shows differences in text, images, formats, styles, tables,
headers, footers, and many other objects.

There are two .docx compare modes, Parent-Child and Sibling:

http://www.perforce.com/perforce/doc.current/manuals/p4v/advanced_files.timelapse_image.html
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• Parent-Child mode is used to show how a file has changed from one version to another; this mode is
set when you select Diff Against Have Revision in P4V.

• Sibling mode is used when there is no direct relationship between the files being compared; it is set,
for example, when you drag and drop .docx files.

For more information about how to select files in P4V for diffing, see Diffing Files and Folders in the
P4V User’s Guide.

Merging Files
If you and another user have edited the same file, Perforce requires you to resolve those changes. One
way of resolving is by merging your changes with the other changes using P4Merge. P4Merge enables
you to compare two text files with a common base file to locate differences and to select the text that
you want in the merged result file. The purple icon (  ) is associated with the file that another user
edited ([italic] their file), and purple bands highlight text that unique to that file. The green icon (  )
is associated with file that you edited ([italic] your file), and green bands highlight text that is in the
second file but not the first file. The [italic] base file is indicated by the yellow icon (  ) and yellow
highlighting indicates text that is in the base file but not in the other files.

In the top half of the window, P4Merge displays the base file surrounded by the two changed versions
of the revision being merged. In the bottom half of the window, P4Merge displays the merge results
file, where you select or enter the text that you want to check in. Make your changes as described
below, and be sure to save them before exiting P4Merge.

Navigate Diffs
To move forward and back through individual differences, or to locate specific text or lines, click the
toolbar buttons listed below.

Go to next/previous diff

Find text

Go to line number

Merge Text
To merge files, you can either choose text from one of the files or enter changes directly into the merge
results file.

Choose Text Chunks

To choose the entire contents of a file, click the corresponding icon in the merge diagram, as shown
below.

http://www.perforce.com/perforce/doc.current/manuals/p4v/files.diff.html
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To choose a single chunk of text from a set of diffs, click the corresponding button to the right of the
chunk, as shown below.

The buttons indicate the origin of the text and the way it was changed, as follows:

Base file text

Same in theirs and base.

Same in theirs and base.

Text added to their file. Not in yours or base.

Text added to your file. Not in theirs or base.

Text deleted from their file.

Text deleted from your file.

Same in yours and theirs, different from base.

Added to both yours and theirs.

Deleted from both yours and theirs.

Note that the buttons are toggles: click once to select the corresponding text, click again to deselect it.

If P4Merge encounters too many changes to display all the required buttons, it displays this button:
 . Click it to view the details.



Chapter 1. Diffing and Merging Files with P4Merge

P4Merge User Guide 5

Edit Text

To edit the text in the merge result file, click on the text in the bottom pane and enter your changes.
Manually-edited text is displayed with a gray highlight, like the middle chunk in the following
example:

Set Preferences
To configure P4Merge settings to display or suppress differences in white space and line endings,
click  or choose File > Comparison Method. To configure other settings, choose Edit > Preferences
(Windows) or P4Merge > Preferences (Mac).

To toggle the display of line numbers, click  .

Note If you are comparing Unicode files, selection of the correct character set is essential.
If you select the wrong character set, P4Merge cannot correctly compare files.
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Appendix  License Statements
Perforce software includes software developed by the University of California, Berkeley and its
contributors. This product includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit (http://www.openssl.org/).

Perforce software includes software from the Apache ZooKeeper project, developed by the Apache
Software Foundation and its contributors. (http://zookeeper.apache.org/)

Perforce software includes software developed by the OpenLDAP Foundation (http://
www.openldap.org/).

http://www.openssl.org/
http://zookeeper.apache.org/
http://www.openldap.org/
http://www.openldap.org/
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