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How to use this guide

This guide provides information on using P4Merge, the visual tool for diffing and merging files. It is
intended for anyone using P4Merge to view the differences between files across time and across
codelines. P4Merge also enables you to merge differing files into one.

This section provides information on typographical conventions, feedback options, and additional
documentation.

Syntax conventions

Helix documentation uses the following syntax conventions to describe command line syntax.

Notation Meaning

IEEEaEalt Must be used in the command exactly as shown.

italics A parameter for which you must supply specific information. For example, for
a serverid parameter, supply the ID of the server.

[-£] The enclosed elements are optional. Omit the brackets when you compose
the command.

m Repeats as much as needed:

e alias-name[[$ (argl) ...
[$ (argn) ] ]=transformation

m Recursive for all directory levels:

« clone perforce:1666 //depot/main/p4...
~/local-repos/main

e p4 repos -e //gra.../rep...

element1 | Either element1 or element2 is required.
element2

Feedback

How can we improve this manual? Email us at manual@perforce.com.

Other documentation

See https://www.perforce.com/support/self-service-resources/documentation.
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Diffing and merging files with P4Merge

P4Merge is a visual diff tool that displays the differences between file versions and helps you to resolve
conflicts and merge competing versions into one.

This chapter includes the following topics:

Diffing text files ... . 6
Navigate diffs ... 6
Diffing iImages ...l 7
View image differenCes . ... .. 8
Merging files ..l 10
Navigate diffs .. 11
Merge teXt il 11
Diffing text files

Inits diff mode, P4Merge enables you to compare two text files to locate differences. (P4Merge can also
diff image files.)
The purple icon (’) is associated with the first file you selected, and purple bands highlight text that is in

the first file but not the second file. The green icon (.) is associated with the second file you selected,
and green bands highlight text that is in the second file but not the first file.

By default, P4Merge displays diffs in a side-by-side layout. However, you may prefer to view changes
closer to each other. In this case, you can switch to single-pane layout. To display diffs in a single pane,
go to View > Single Pane Diff Layout. In single-pane mode, deleted text is shown using strike-through
text.

1 m—

To toggle the display of line numbers, click =
For information on diffing files from within P4V, see Diffing files in the P4V User Guide.
To diff files:
1. GotoFile > New Merge or Diff.
2. Inthe Choose Files dialog, on the Diff tab, specify the two files to be compared.
3. Click OK.

P4Merge shows each file in its own pane, with differences highlighted in blue and green,
respectively.

Navigate diffs

To move forward and back through individual differences, or to locate specific text or lines, click the
toolbar buttons listed below.


https://www.perforce.com/perforce/doc.current/manuals/p4v/#P4V/advanced_files.text_diff.html
http://www.perforce.com/perforce/doc.current/manuals/p4v/index.html

Diffing images

Go to next diff

Go to previous diff

Find text

o ¥

Go to line number

Edit text

If needed, you can edit files directly in P4AMerge, provided you are viewing them side by side. In Double
Pane Diff Layout, for files that are available in the workspace and writable, the edit file buttons become
available in the toolbar:

» Select % to edit the file in the left pane.
n Select ¥ to edit the file in the right pane.

The edit pane opens at the bottom of the window. Make your changes and save the file.

Diffing images
P4Merge lets you diff the following image file types:

= BMP

s GIF

s JPG, JPEG
s PNG

= PBM

s PGM

s PPM

s TIFF

= XBM

s XPM

You can compare two different image files or two revisions of the same image.
For information on diffing images from within P4V, see Diffing images in the P4V User Guide.
To diff two different image files:
1. GotoFile > New Merge or Diff.
2. Inthe Choose Files dialog, on the Diff tab, specify the two files to compare and click OK.

The two files open side by side.
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View image differences

View image differences

P4Merge can display image differences side by side (H-) or as an overlay ().
To enlarge or reduce the displayed images:

m Use the zoom slider below the images in the left pane (indicated in the following figure) or choose
the desired display option from the View menu.

Viewer Control @ //depot/david/ogre.gif#3
o @) @

//depot/david/ogre.gif#4

Highlight differences:

Type: GIF Image Width: 640 pixels Type: GIF Image Width: 640 pixels
File size: 113.7 KB Height: 480 pixels File size: 113.8 KB Height: 480 pixels
Format: RGB w/ alpha channel Horizontal resolution: 72 dpi Format: RGB w/ alpha channel Horizontal resolution: 72 dpi

Depth:  32-bit Vertical resolution: 72 dpi Depth:  32-bit Vertical resolution: 72 dpi

100% 100%

To highlight differences:



View image differences

1. Select the Highlight Differences check box.

2. Use the adjacent slider (indicated in the following figure) to increase or decrease sensitivity.

P4Merge highlights identical areas in gray and differences in yellow, in both images.

Viewer Control ® //depot/david/ogre.gif#3
Mjth ()3

V| Highlight differences:

f—

Type: GIF Image Width: 640 pixels
File size: 113.7 KB Height: 480 pixels
Format: RGB w/ alpha channel Horizontal resolution: 72 dpi
Depth:  32-bit Vertical resolution: 72 dpi

100%

To blend or separate overlaid image:

Type:

File size:
Format:

Depth:

100%

//depot/david/ogre.gif#4

GIF Image Width: 640 pixels
113.8 KB Height: 480 pixels
RGB w/ alpha channel Horizontal resolution: 72 dpi

32-bit Vertical resolution: 72 dpi



Merging files

1. Click the overlay icon
2. Drag the vertical slider (indicated in the following figure) up or down, as needed.

To blend images equally, center the slider. To increase the amount of an image used in the
composite, move the slider up or down toward the respective image.

Following is an overlay example. The skull in the groin area is available in the bottom image but
not in the top.

Viewer Control (5)
m ot

Highlight differences:

100%

Tip
You can also view image revisions sequentially in Time-lapse View. For more information, see
Viewing Image File History with Time-lapse View in the P4V User Guide.

Merging files

P4Merge enables you to compare two text files with a common base file to locate differences and to
select the text that you want in the merged result file. The purple icon (') is associated with the file that

another user edited (theirfile), and purple bands highlight text that is unique to that file. The green icon (’
)is associated with file that you edited (yourfile), and green bands highlight text that is in the second file

but not the first file. The base file is indicated by the yellow icon ("), and yellow highlighting indicates
text that is in the base file but not in the other files.

10
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Navigate diffs

In the top half of the window, P4Merge displays the base file surrounded by the two changed versions of
the revision being merged. In the bottom half of the window, P4Merge displays the merge results file,
where you select or enter the text that you want to check in. Make your changes as described below, and
be sure to save them before exiting P4Merge.

For information on merging files from within P4V, see Merging files and Resolving files in the P4V User
Guide.

To merge files:
1. GotoFile > New Merge or Diff.
2. Inthe Choose Files dialog, on the Merge tab, specify the base file and the two files to be merged.
3. Click OK.

P4Merge shows each file in its own pane, with the base file in the middle. The bottom pane shows
the merge results file, a consolidated, merged version of all files.

Navigate diffs

To move forward and back through individual differences, or to locate specific text or lines, click the
toolbar buttons listed below.

Go to next diff

Go to previous diff

Find text

o 2 ¥

Go to line number

Merge text

To merge files, you can either choose text from one of the files or enter changes directly into the merge
results file.

Choose Text Chunks

To choose the entire contents of a file, click the corresponding icon in the merge diagram, as shown
below.

Base:

®-| Source:
Target:
Merge:

To choose a single chunk of text from a set of diffs, click the corresponding button to the right of the
chunk, as shown below.

11
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Merge text

---if-(luser.isEmpty()-&& -mUsersModel- >inListCache(user): e
-------- &&:checkout-==-true)

........ sel -=-true;

-------- sel-=-mUsersView->selectitem(-mUsersModel->getForm(-user-));
<««if-(luser.isEmpty():-&& mUsersModel- >inListCache(user))

........ sel a =.true;

-------- sel-=-mUsersView->selectltem(-mUsersModel->getForm(-user-)-);

The buttons indicate the origin of the text and the way it was changed, as follows:

Base file text

Same in theirs and base.

Same in yours and base.

Text added to their file. Not in yours or base.

Text added to your file. Not in theirs or base.

Text deleted from their file.

Text deleted from your file.

'TEREERXK

® Same in yours and theirs, different from base.

9
“

Added to both yours and theirs.
& — Deleted from both yours and theirs.

Note that these are toggle buttons: Click once to select the corresponding text; click again to deselect it.

If P4Merge encounters too many changes to display all the required buttons, it displays this button:
@ ... Clickit to view the details.

Edit text

To edit the text in the merge result file, click on the text in the bottom pane and enter your changes.
Manually edited text is displayed with a gray highlight, like the middle chunk in the following example:

12



Merge text

L ¥ L o ey TIAEL T
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Setting preferences

Setting preferences

In P4Merge, you can set preferences using the View menu, the toolbar, or the Preferences dialog.
Toolbar and View menu settings are temporary and do not carry over to future sessions. To configure
default settings for application font, text format, file format, application language, icon scaling,
comparison method, or web services, go to Edit > Preferences (Windows) or P4Merge > Preferences
(Mac).

To configure P4Merge settings for the current session to:

= Display or suppress differences in white space and line endings for the current session, click B,
or choose File > Comparison Method.

m Show inline differences, click =

m Adjust tab spacing, insert spaces instead of tabs, or show tabs and spaces, click View > Tab
and Space Options and select the required settings..

m Change the font for the session, click View > Font.
Note
If you are comparing Unicode files, selection of the correct character set is essential. If you select the

wrong character set, P4Merge cannot correctly diff files. For configuration, go to File > Character
Encoding or Edit > Preferences.

14



A

access level

A permission assigned to a user to control which commands the user can execute. See also the
'protections' entry in this glossary and the 'p4 protect' command in the P4 Command Reference.

admin access

An access level that gives the user permission to privileged commands, usually super privileges.

APC

The Alternative PHP Cache, a free, open, and robust framework for caching and optimizing PHP
intermediate code.

archive

1. For replication, versioned files (as opposed to database metadata). 2. For the 'p4 archive'
command, a special depotin which to copy the server data (versioned files and metadata).

atomic change transaction

Grouping operations affecting a number of files in a single transaction. If all operations in the
transaction succeed, all the files are updated. If any operation in the transaction fails, none of the files
are updated.

avatar

A visual representation of a Swarm user or group. Avatars are used in Swarm to show involvement in
or ownership of projects, groups, changelists, reviews, comments, etc. See also the "Gravatar" entry
in this glossary.

base

The file revision, in conjunction with the source revision, used to help determine what integration
changes should be applied to the target revision.
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binary file type

A Helix Server file type assigned to a non-text file. By default, the contents of each revision are stored
in full, and file revision is stored in compressed format.

branch

(noun) A set of related files that exist at a specific location in the Perforce depot as a result of being
copied to that location, as opposed to being added to thatlocation. A group of related files is often
referred to as a codeline. (verb) To create a codeline by copying another codeline with the 'p4
integrate', 'p4 copy', or 'p4 populate' command.

branch form

The form that appears when you use the '‘p4 branch' command to create or modify a branch
specification.

branch mapping

Specifies how a branch is to be created or integrated by defining the location, the files, and the
exclusions of the original codeline and the target codeline. The branch mapping is used by the
integration process to create and update branches.

branch view

A specification of the branching relationship between two codelines in the depot. Each branch view
has a unique name and defines how files are mapped from the originating codeline to the target
codeline. This is the same as branch mapping.

broker

Helix Broker, a server process that intercepts commands to the Helix Server and is able to run scripts
on the commands before sending them to the Helix Server.

Cc

change review

The process of sending email to users who have registered their interest in changelists thatinclude
specified files in the depot.

16
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changelist

A list of files, their version numbers, the changes made to the files, and a description of the changes
made. A changelist is the basic unit of versioned work in Helix Server. The changes specified in the
changelist are not stored in the depot until the changelistis submitted to the depot. See also atomic
change transaction and changelist number.

changelist form

The form that appears when you modify a changelist using the 'p4 change' command.

changelist number

An integer that identifies a changelist. Submitted changelist numbers are ordinal (increasing), but not
necessarily consecutive. For example, 103, 105, 108, 109. A pending changelist number might be
assigned a different value upon submission.

check in

To submit a file to the Helix Server depot.

check out

To designate one or more files for edit.

checkpoint

A backup copy of the underlying metadata at a particular momentin time. A checkpoint can recreate
db.user, db.protect, and other db.* files. See also metadata.

classic depot

A repository of Helix Server files that is not streams-based. The default depot name is depot. See
also default depot and stream depot.

client form

The form you use to define a client workspace, such as with the 'p4 client' or 'p4 workspace'
commands.

client name

A name that uniquely identifies the current client workspace. Client workspaces, labels, and branch
specifications cannot share the same name.

17
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client root

The topmost (root) directory of a client workspace. If two or more client workspaces are located on
one machine, they should not share a client root directory.

client side

The right-hand side of a mapping within a client view, specifying where the corresponding depot files
are located in the client workspace.

client workspace

Directories on your machine where you work on file revisions that are managed by Helix Server. By
default, this name is set to the name of the machine on which your client workspace is located, but it
can be overridden. Client workspaces, labels, and branch specifications cannot share the same
name.

code review

A process in Helix Swarm by which other developers can see your code, provide feedback, and
approve or reject your changes.

codeline

A set of files that evolve collectively. One codeline can be branched from another, allowing each set
of files to evolve separately.

comment

Feedback provided in Helix Swarm on a changelist, review, job, or a file within a changelist or
review.

commit server

A server that is part of an edge/commit system that processes submitted files (checkins), global
workspaces, and promoted shelves.

conflict

1. A situation where two users open the same file for edit. One user submits the file, after which the
other user cannot submit unless the file is resolved. 2. A resolve where the same line is changed
when merging one file into another. This type of conflict occurs when the comparison of two files to a
base yields different results, indicating that the files have been changed in different ways. In this
case, the merge cannot be done automatically and must be resolved manually. See file conflict.
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copy up

A Helix Server best practice to copy (and not merge) changes from less stable lines to more stable
lines. See also merge.

counter

A numeric variable used to track variables such as changelists, checkpoints, and reviews.

CSRF

Cross-Site Request Forgery, a form of web-based attack that exploits the trust that a site hasin a
user's web browser.

D

default changelist

The changelist used by a file add, edit, or delete, unless a numbered changelist is specified. A
default pending changelist is created automatically when a file is opened for edit.

deleted file

In Helix Server, a file with its head revision marked as deleted. Older revisions of the file are still
available. in Helix Server, a deleted file is simply another revision of the file.

delta

The differences between two files.

depot

A file repository hosted on the server. A depotis the top-level unit of storage for versioned files (depot
files or source files) within a Helix Core Server. It contains all versions of all files ever submitted to
the depot. There can be multiple depots on a single installation.

depot root

The topmost (root) directory for a depot.

depot side

The left side of any client view mapping, specifying the location of files in a depot.
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depot syntax

diff

Helix Server syntax for specifying the location of files in the depot. Depot syntax begins with: //depot/

(noun) A set of lines that do not match when two files are compared. A conflict is a pair of unequal
diffs between each of two files and a base. (verb) To compare the contents of files or file revisions.
See also conflict.

donor file

E

The file from which changes are taken when propagating changes from one file to another.

edge server

A replica server that is part of an edge/commit system that is able to process most read/write
commands, including 'p4 integrate’, and also deliver versioned files (depot files).

exclusionary access

A permission that denies access to the specified files.

exclusionary mapping

A view mapping that excludes specific files or directories.

F

file conflict
In a three-way file merge, a situation in which two revisions of a file differ from each other and from
their base file. Also, an attempt to submit a file thatis not an edit of the head revision of the file in the
depot, which typically occurs when another user opens the file for edit after you have opened the file
for edit.

file pattern

20

Helix Server command line syntax that enables you to specify files using wildcards.
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file repository

The master copy of all files, which is shared by all users. In Helix Server, this is called the depot.

file revision

A specific version of a file within the depot. Each revision is assigned a number, in sequence. Any
revision can be accessed in the depot by its revision number, preceded by a pound sign (#), for
example testfile#3.

file tree

All the subdirectories and files under a given root directory.

file type

An attribute that determines how Helix Server stores and diffs a particular file. Examples of file types
are text and binary.

fix

A job that has been closed in a changelist.

form

A screen displayed by certain Helix Server commands. For example, you use the change form to
enter comments about a particular changelist to verify the affected files.

forwarding replica

A replica server that can process read-only commands and deliver versioned files (depot files). One
or more replicate servers can significantly improve performance by offloading some of the master
server load. In many cases, a forwarding replica can become a disaster recovery server.

G

Git Fusion

A Perforce product that integrates Git with Helix, offering enterprise-ready Git repository
management, and workflows that allow Git and Helix Server users to collaborate on the same
projects using their preferred tools.
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graph depot

A depot of type graph thatis used to store Git repos in the Helix Server. See also Helix4Git.

Gravatar

gravatar.com is a third party service that you can subscribe to, gravatar enables you to upload an
image that you can use in Swarm. When configured, Swarm will attempt to fetch your avatar from
gravatar.com and use it within Swarm. If your avatar is not found on gravatar.com, Swarm will use
one of its own default avatars to represent your activity. See also the "avatar” entry in this glossary.

group

A feature in Helix Server that makes it easier to manage permissions for multiple users.

H

have list

The list of file revisions currently in the client workspace.

head revision

The most recent revision of a file within the depot. Because file revisions are numbered sequentially,
this revision is the highest-numbered revision of that file.

Helix Server

The Helix Server depot and metadata; also, the program that manages the depot and metadata, also
called Helix Core Server.

Helix TeamHub

A Perforce management platform for code and artifact repository. TeamHub offers built-in support for
Git, SVN, Mercurial, Maven, and more.

Helix4Git

Perforce solution for teams using Git. Helix4 Git offers both speed and scalability and supports hybrid
environments consisting of Git repositories and 'classic' Helix Server depots.
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iconv

iconv is a PHP extension that performs character set conversion, and is an interface to the GNU
libiconv library.

integrate

To compare two sets of files (for example, two codeline branches) and determine which changes in
one setapply to the other, determine if the changes have already been propagated, and propagate
any outstanding changes from one set to another.

job
A user-defined unit of work tracked by Helix Server. The job template determines what information is
tracked. The template can be modified by the Helix Server system administrator. A job describes

work to be done, such as a bug fix. Associating a job with a changelist records which changes fixed
the bug.

job daemon

A job daemon is a program that checks the Helix Server machine daily to determine if any jobs are
open. If so, the daemon sends an email message to interested users, informing them the number of
jobs in each category, the severity of each job, and more.

job specification

A form describing the fields and possible values for each job stored in the Helix Server machine.

job view

A syntax used for searching Helix Server jobs.

journal

A file containing a record of every change made to the Helix Server's metadata since the time of the
last checkpoint. This file grows as each Helix Server transaction is logged. The file should be
automatically truncated and renamed into a numbered journal when a checkpoint is taken.
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journal rotation

The process of renaming the current journal to a numbered journal file.

journaling

The process of recording changes made to the Helix Server's metadata.

L
label
A named list of user-specified file revisions.
label view
The view that specifies which filenames in the depot can be stored in a particular label.
lazy copy
A method used by Helix Server to make internal copies of files without duplicating file contentin the
depot. A lazy copy points to the original versioned file (depot file). Lazy copies minimize the
consumption of disk space by storing references to the original file instead of copies of the file.
license file
A file that ensures that the number of Helix Server users on your site does not exceed the number for
which you have paid.
list access
A protection level that enables you to run reporting commands but prevents access to the contents of
files.
local depot
Any depot located on the currently specified Helix Server.
local syntax

The syntax for specifying a filename that is specific to an operating system.
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lock

1. Afile lock that prevents other clients from submitting the locked file. Files are unlocked with the 'p4
unlock' command or by submitting the changelist that contains the locked file. 2. A database lock that
prevents another process from modifying the database db.* file.

Error output from the Helix Server. To specify a log file, set the P4LOG environment variable or use
the p4d -L flag when starting the service.

mapping

A single line in a view, consisting of a left side and a right side that specify the correspondences
between files in the depot and files in a client, label, or branch. See also workspace view, branch
view, and label view.

MDS checksum

The method used by Helix Server to verify the integrity of versioned files (depot files).

merge

1. To create new files from existing files, preserving their ancestry (branching). 2. To propagate
changes from one set of files to another. 3. The process of combining the contents of two conflicting
file revisions into a single file, typically using a merge tool like P4Merge.

merge file

A file generated by the Helix Server from two conflicting file revisions.

metadata

The data stored by the Helix Server that describes the files in the depot, the current state of client
workspaces, protections, users, labels, and branches. Metadata includes all the data stored in the
Perforce service except for the actual contents of the files.

modification time or modtime

The time a file was last changed.
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MPM

Multi-Processing Module, a component of the Apache web server that is responsible for binding to
network ports, accepting requests, and dispatch operations to handle the request.

N

nonexistent revision

A completely empty revision of any file. Syncing to a nonexistent revision of a file removes it from
your workspace. An empty file revision created by deleting a file and the #none revision specifier are
examples of nonexistent file revisions.

numbered changelist

A pending changelist to which Helix Server has assigned a number.

o

opened file
A file that you are changing in your client workspace that is checked out. If the file is not checked out,
opening itin the file system does not mean anything to the versioning engineer.

owner
The Helix Server user who created a particular client, branch, or label.

P

p4
1. The Helix Core Server command line program. 2. The command you issue to execute commands
from the operating system command line.

pad
The program that runs the Helix Server; p4d manages depot files and metadata.

P4PHP

The PHP interface to the Helix API, which enables you to write PHP code that interacts with a Helix
Server machine.
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PECL

PHP Extension Community Library, a library of extensions that can be added to PHP to improve and
extend its functionality.

pending changelist

A changelist that has not been submitted.

project

In Helix Swarm, a group of Helix Server users who are working together on a specific codebase,
defined by one or more branches of code, along with options for a job filter, automated test
integration, and automated deployment.

protections

The permissions stored in the Helix Server’s protections table.

proxy server

A Helix Server that stores versioned files. A proxy server does not perform any commands. It serves
versioned files to Helix Server clients.

R

RCS format

Revision Control System format. Used for storing revisions of text files in versioned files (depot files).
RCS format uses reverse delta encoding for file storage. Helix Server uses RCS format to store text
files. See also reverse delta storage.

read access
A protection level that enables you to read the contents of files managed by Helix Server but not

make any changes.

remote depot

A depot located on another Helix Server accessed by the current Helix Server.
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replica

A Helix Server that contains a full or partial copy of metadata from a master Helix Server. Replica
servers are typically updated every second to stay synchronized with the master server.

repo

A graph depot contains one or more repos, and each repo contains files from Git users.

reresolve

The process of resolving a file after the file is resolved and before itis submitted.

resolve

The process you use to manage the differences between two revisions of a file. You can choose to
resolve conflicts by selecting the source or target file to be submitted, by merging the contents of
conflicting files, or by making additional changes.

reverse delta storage

The method that Helix Server uses to store revisions of text files. Helix Server stores the changes
between each revision and its previous revision, plus the full text of the head revision.

revert

To discard the changes you have made to a file in the client workspace before a submit.

review access

A special protections level that includes read and list accesses and grants permission to run the p4
review command.

review daemon

A review daemon is a program that periodically checks the Helix Server machine to determine if any
changelists have been submitted. If so, the daemon sends an email message to users who have
subscribed to any of the files included in those changelists, informing them of changes in files they
are interested in.

revision number

A number indicating which revision of the file is being referred to, typically designated with a pound
sign (#).
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revision range

A range of revision numbers for a specified file, specified as the low and high end of the range. For
example, myfile#5,7 specifies revisions 5 through 7 of myfile.

revision specification

A suffix to a filename that specifies a particular revision of that file. Revision specifiers can be
revision numbers, a revision range, change numbers, label names, date/time specifications, or client
names.

RPM

RPM Package Manager is a tool, and package format, for managing the installation, updates, and
removal of software packages for Linux distributions such as Red Hat Enterprise Linux, the Fedora
Project, and the CentOS Project.

S

server data
The combination of server metadata (the Helix Server database) and the depot files (your
organization's versioned source code and binary assets).

server root
The topmost directory in which p4d stores its metadata (db.* files) and all versioned files (depot files
or source files). To specify the server root, set the P4AROOT environment variable or use the p4d -r
flag.

service
In the Helix Core Server, the shared versioning service that responds to requests from Helix Server
client applications. The Helix Server (p4d) maintains depot files and metadata describing the files
and also tracks the state of client workspaces.

shelve
The process of temporarily storing files in the Helix Server without checking in a changelist.

status

For a changelist, a value that indicates whether the changelistis new, pending, or submitted. For a
job, a value that indicates whether the job is open, closed, or suspended. You can customize job
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statuses. For the 'p4 status' command, by default the files opened and the files that need to be
reconciled.

stream

A branch with additional intelligence that determines what changes should be propagated and in
what order they should be propagated.

stream depot

A depot used with streams and stream clients.

submit

To send a pending changelist into the Helix Server depot for processing.

super access

An access level that gives the user permission to run every Helix Server command, including
commands that set protections, install triggers, or shut down the service for maintenance.

symlink file type

A Helix Server file type assigned to symbolic links. On platforms that do not support symbolic links,
symlink files appear as small text files.

sync

To copy a file revision (or set of file revisions) from the Helix Server depot to a client workspace.

T

target file

The file that receives the changes from the donor file when you integrate changes between two
codelines.

text file type

Helix Server file type assigned to a file that contains only ASCII text, including Unicode text. See also
binary file type.
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theirs

The revision in the depot with which the client file (your file) is merged when you resolve a file
conflict. When you are working with branched files, theirs is the donor file.

three-way merge

The process of combining three file revisions. During a three-way merge, you can identify where
conflicting changes have occurred and specify how you want to resolve the conflicts.

trigger

A script automatically invoked by Helix Server when various conditions are met. (See Helix Core
Server Administrator Guide: Fundamentals on "Using triggers to customize behavior".)

two-way merge

The process of combining two file revisions. In a two-way merge, you can see differences between
the files.

typemap

A table in Helix Server in which you assign file types to files.

U

user

The identifier that Helix Server uses to determine who is performing an operation.

Vv

versioned file

Source files stored in the Helix Server depot, including one or more revisions. Also known as a depot
file or source file. Versioned files typically use the naming convention 'filenamev' or '1.changelist.gz'.

view

A description of the relationship between two sets of files. See workspace view, label view, branch
view.
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w

wildcard

A special character used to match other characters in strings. The following wildcards are available
in Helix Server: * matches anything except a slash; ... matches anything including slashes; %%0
through % %39 is used for parameter substitution in views.

workspace

See client workspace.

workspace view

A set of mappings that specifies the correspondence between file locations in the depot and the
client workspace.

write access

A protection level that enables you to run commands that alter the contents of files in the depot. Write
access includes read and list accesses.

X

XSS

Cross-Site Scripting, a form of web-based attack that injects malicious code into a user's web
browser.

Y

yours

The edited version of a file in your client workspace when you resolve a file. Also, the target file when
you integrate a branched file.



License statements

Perforce Software includes software developed by the University of California, Berkeley and its
contributors. This product includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit (http://www.openssl.org/).

Perforce Software includes software from the Apache ZooKeeper project, developed by the Apache
Software Foundation and its contributors. (http://zookeeper.apache.org/)

Perforce Software includes software developed by the OpenLDAP Foundation
(http://www.openldap.org/).
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