Setting Perforce preferences

To set Perforce preferences in Visual Studio, go to Tools>Options. You can specify preferences on the following nodes in the Options dialog under Source Control:

You can specify keyboard shortcuts for P4VS commands under Tools>Options>Environment>Keyboard.

Perforce - Connections

Set the following preferences to determine how you connect to the shared Perforce service in Visual Studio:

When opening a project under source control:

Opening and closing connections:

Perforce - Data Retrieval

Set the following preferences to determine how P4VS retrieves data from the shared Perforce service:

Perforce - Diff/Merge

To set the default diff application, select one of the following:

  1. P4Merge: Perforce's companion diff tool.
  2. Other application: Browse to your preferred diff tool.
  3. To specify arguments for third-party diff applications, enter %1 for the name of the first file and %2 for the name of the second file in the Arguments field. Perforce replaces these placeholders with the actual filenames when calling the diff application.

To set the default merge application, select one of the following:

  1. P4Merge: Perforce's companion merge tool.
  2. Other application: Browse to your preferred merge tool.
  3. To specify arguments for third-party merge applications, enter the following replaceable parameters in the Arguments field:

    Perforce replaces these placeholders with the actual filenames when calling the merge application.

Perforce - General

Set the following display and file behavior preferences:

Display:

Files and folders:

Project and solution files:

Perforce - Ignoring Files

To avoid adding and checking in files that do not belong in the repository, you can exclude individual files or file types (for example, build or release artifacts) from source control using Ignore Lists. For more information, see Excluding files from Perforce.

You can set the following preferences:

Perforce - Logging

Set the following logging preferences. You can view P4VS log messages in the Output window in Visual Studio if you select Perforce Source Control in the Show output from: drop-down list in the Output window.

Keyboard shortcuts

Go to Tools>Options>Environment>Keyboard. You can find P4VS commands by entering P4VS in the Show commands containing: field.

For more information about creating keyboard shortcuts in Visual Studio, see the Microsoft Visual Studio help.


Copyright Perforce Software 2003-2014. All Rights Reserved.