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How to use this guide

This guide tells you how to use P4Admin, a GUI for administrating Helix Server connections. It is
intended for anyone using P4Admin to perform basic Helix Server administrative tasks. Access to the
complete set of administrative tools requires P4, the c ommand-line client.

Feedback

How can we improve this manual? Email us at manual@perforce.com.

Other Helix Server documentation

See https://www.perforce.com/support/self-service-resources/documentation.

Syntax conventions

Helix documentation uses the following syntax conventions to describe command line syntax.

Notation Meaning

Titeral Must be used in the command exactly as shown.

italics A parameter for which you must supply specific information. For example, for
a serverid parameter, supply the ID of the server.

[-f] The enclosed elements are optional. Omit the brackets when you compose
the command.

m Repeats as much as needed:

. alias-name[[$(argl)...
[$Cargn)]]=transformation

m Recursive for all directory levels:

. clone perforce:1666 //depot/main/p4...
~/1ocal-repos/main

. p4 repos -e //gra.../rep...

element1 | Either element1 or element2 is required.
element2

S
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Administering Helix Server using P4Admin

P4Admin provides a graphical user interface for performing basic Helix Server administration tasks. This
chapter discusses the following topics:
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To access P4Admin from within P4V, go to Tools > Admininstration.

Home page

The Administration home page enables users with super and adm1i n permissions to view and use the
following:

m Server information: displays details about the server to which you are connected.

m Disk space usage: displays details about server disk space usage.

m Security level: displays authentication level required by users who access the server.
= Account management shortcuts: displays links to common tasks.

m User licenses: displays details about license count and expiration.

m Inactive users: displays details about users who have not accessed their account in the period of
time you specify.

Server connections

To administer a server, you must first connect to it as a user that has been granted superuser privilege for
the server. (If your user does not have superuser privilege, you can still administer users and groups, but
cannot manage permissions or define depots.)



Managing depots

To connect to a server, choose Connections > Open Connection. Specify the desired settings and
click OK. To administer a server, activate the connection by clicking its entry in the Connections pane.
To remove a connection, context-click it and choose Close Connection.

P4Admin retains all of the connections that you define, so you do not need to reenter them the next time
you launch the tool.

Managing depots

If you have super user permission for the Helix Server instance to which you are connected, you can
manage the depots that it contains. Specifically, you can:

m Display details about a depot
m Create, edit, or delete depots

m Obliterate files from a depot

Warning
Obliterate with extreme caution. Obliteration permanently removes all traces of the specified files

from the Helix server, including revision records and metadata (such as references in labels and client
workspace specifications). Files in client workspaces are left untouched, but are no longer recognized
as being under Helix Server control.

Managing users and groups

All users can display lists of users and groups using P4Admin, but only users with admin or super
permissions can make changes. For details about access levels, refer to the Helix Versioning Engine
Administrator Guide: Fundamentals.

To view the users defined for the server to which you are connected, choose Tools >
Administration and click the Users & Groups tab.

To display details about a user, click the desired user specification. The details about that user are
displayed at the bottom of the Users tab.

To create a user:

1. InP4V, select Tools > Administration. P4Admin opens.

2. Choose File > New > User.
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Managing permissions

The User dialog is displayed.

3. Enter userinformation as follows. Click OK after making your entries.

User The Helix Server user name.

Password  The password (if any) required for the user to connect to the server.

Email The user's email address.
Full The user’s real name.
name

Job view (Optional) Criteria specifying which jobs are automatically included on any new
changelists created by the user. Example: User=bruno Status=open.
For details, refer to the description of the p4 jobs-e flag in the Perforce
Command Reference.

Reviews Files of interest to the user, specified using depot syntax. When changelists
that affect the file are submitted, the user receives email notification of the
change. Note that you can also specify files of interest by clicking the Reviews
tab.

Groups Groups to which the user belongs. To add the user to a group, enter the name of
the group in the Group field and click Add, or click Browse, select the group,
and click OK.

To change your password: choose Administration > Change Password.

To display the groups to which a user belongs, expand the user in the Users pane. To display the
users in a group, expand the group in the Groups pane.

To edit a user or group, context-click the user or group you want to edit and choose Edit.

To see the areas of the depot tree to which a user has access, context-click the user, and choose
Show Permissions. The Permissions tab is displayed, with the selected user highlighted.

To add a user to a group, drag the user from the Users pane to the desired group. To remove a user
from a group, context-click the user in the group and choose Remove.

To edit the groups to which a user belongs:

1. Context-click the user and choose Edit User.
The User dialog is displayed.
2. Edit the list displayed in the Group membership field.

Managing permissions

For details about how permissions work within Helix Server, see the Helix Versioning Engine
Administrator Guide: Fundamentals.
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View permissions

View permissions

To display the files and folders to which a user has access, click the desired user on the Users tab.

To display the files and folders to which users in a group have access, click the desired group on
the Groups tab.

To display the groups and users that have access to a file or folder, click the file or folder in the
Depot Tree tab.

To see which lines of the protections table control access to a user, group, or area of the depot,
click the user, group or folder of interest. The corresponding line in the protections table is highlighted. (If
a user or group is neither granted nor denied access to a path by means of any entries in the protections
table, the depot path displays "no access" and the "granted to" field is blank.)

To filter out lines in the right-hand pane, use the Access Level sliders to set the lowest and highest
levels. The areas of the depot associated with the highlighted range of access values are displayed.

To see only those permissions that apply to a user’s workstation, enter the IP address of the
workstation in the Host IP filter field. For example, permissions lines with a host value of
92.168.*.%and192.168.1. * both apply to a workstationat 192.168.1.10.

To show files in the Depot Tree, click Show files.
Note

Virtual streams do not appear in the Depot Tree on the Permissions tab. Virtual streams map their
parent’s paths, and permissions for virtual streams are therefore always set for the parent’s paths.

Edit the protections table

The protections table is displayed in the bottom pane of the screen. It is a representation of the table used
by the p4 protect command, with exclusionary lines shown in red.

To edit the protections table, use the built-in editor or click E to edit the protections table as text.

To deny access to a specific portion of the depot to a user or group, use an exclusionary mapping: place a
dash (-) in front of the path in the Folder/File field. Exclusionary mappings apply to all access levels,
even though only one access level can be selected in the Access Level field.

The following table describes the fields in the protections table.



Configuring P4Admin preferences

Access The permission being granted. Each permission level includes all lower-level
Level permissions, except forreview.
m super-access to all commands and command options
m admin- permits those administrative commands and command options that
don’t affect server security
m write- users can submit open files
m open- users can open files for add, edit, delete, and integrate
m read- users can sync, diff, and print files
m list- users can see names but not contents of files; users can see all non-file
related metadata (workspaces, users, changelists, jobs, etc.
= review- allows access tothe p4 review command; intended for
automated processes, implies read access.

User/Group Indicates whether this line applies to a Perforce user or group.

Name A Helix Server user name or group name; can be wildcarded.

Host The IP address of a client host; can be wildcarded.

Folder/File The part of the depot to which access is being granted or denied. To deny access to
a depot path, preface the path with a dash (-). Exclusionary mappings apply to all
access levels, regardless of the access level specified in the first field.

Comment Optional description of table entry.

Configuring P4Admin preferences

To configure settings for P4Admin, choose Edit > Preferences (Windows) or P4Admin > Preferences
(Mac). The Preferences dialog includes the following configuration pages:

Connections
Logging ...
Display ....
Files .......

Tools ......

Click Applyto save your changes. Click OKto save your changes and exit the dialog.

Connections

You can configure the following settings for connecting to Perforce servers:

When the application launches:



Logging

m Restore all previously opened connections: Do not prompt for connection settings; reconnect
to the server to which you were connected during your last session.

Opening and closing connections:

m Use IP-specific tickets when logging in: Specifies whether your login ticket is restricted to the
IP address from which you are connecting.

= Automatically log off when closing a connection: Specifies whether your ticket is invalidated
when you log out.

Logging
You can configure the following logging options:

Log pane options:

= Show p4 reporting commands: Specifies whether the log pane in the Administration Tool
window displays all commands issued by the Administration Tool, including commands issued by
the Administration Tool to obtain status information from the Perforce server.

Logging to a file:
=m Enable logging to file: Logs Administration Tool activity to the specified file.

o Name: Specifies the name and location of the log file.

» Size: Specifies the maximum size of the log file.

Display
You can configure the following Administration Tool display and localization options:
Application:

= Show the What’s New in P4V page after upgrading:Display the What's New page as atabin
the P4V window.

m Dates: Sets the date format used throughout the Administration Tool.
« Use OS format for dates: Use the format that your operating system uses.

. Format dates using Perforce standard (yyyy/mm/dd hh:mm:ss)
Localization:

= Language used for application menus, labels, and dialogs (requires restart): Select
language.
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Files

m Set encoding for all connections to: Sets the character encoding for connections to unicode-

mode Perforce servers.

If you do not set the encoding here, you are prompted to enter the character encoding every time
you set up a connection to a unicode-mode Perforce server. The encoding that you set here does
not affect server connections whose character encoding has already been set at connection. If
you are unsure which setting to choose, consult your Perforce administrator.

Files

You can configure the way the Administration Tool displays files and file icons:

m Show Perforce filetype for files in the Workspace and Depot tree:Toggles display of filetype

in the tree panes.

Show revision information for files in the Workspace and Depot tree:Toggles display of
revision numbers in the tree panes.

Render thumbnails for Maya files:Enables the Administration Tool to display thumbnail images
of Maya media files.

File preview font:Specifies the font that the Administration Tool uses to display files in the
preview pane.

Click Show fixed sized fonts onlyto limit the selection in the font drop-down to fixed-sized fonts.

Behavior

You can configure the following Administration Tool user interface behaviors:

Prompts:

Warn before reverting files: Specifies whether the Administration Tool displays a prompt before
reverting files.

Prompt for changelist when checking out, adding, or deleting files: Specifies whether the
Administration Tool displays the "Choose changelist" dialog when you open files.

Prompt to get latest revision when checking out files that are out of date

Prompt when connecting to a new Perforce Sandbox: Specifies whether the Administration
Tool displays a prompt before you connect to a new Perforce Sandbox.

Drag and drop:

Enable integration on directory-to-directory drag and drop: Launches the Merge/Integrate
dialog when you drop a folder on another folder.

Enable diff comparisons on file-to-file drag and drop: Launches the Diff dialog when you drop
afile on anotherfile.
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Tools

Tools

You can configure the following Revision Graph and Time-Lapse View options:

Revision Graph:

m Use software rendering for Revision Graph: Enable only if your machine is having problems
rendering Revision Graph output. For details, consult the Perforce Knowledge base.

= Limit Revision Graph to ancestors and descendants: Controls how much of a file’s integration
history is displayed.

Time-Lapse View:

= Show branch history in Time-lapse View by default: Specifies whether Time-lapse View
displays the integration/merge history for the selected file by default. You can also toggle the
display of integration history in Time-lapse View.

Editor

To associate file types with the applications you use to edit them:

1. Click Add.

2. Select afile extension from the drop-down list.
3. Enter or browse for the associated application.
4

(Optional) Select Always use the selected application to open files of this typeto set the
application as the default.

5. Click Save.

You can enter as many applications as you like for each extension. All of the applications will appear as
options when you context-click a file in the Administration Tool and select Open With.

Note
Any application that you've used to open a file from the context menu in the Administration Tool

appears by default as an associated application on the Editor page in the Administration Tool
Preferences dialog, unless you remove it.

Diff

To set the default diff application, select one of the following:
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Diff

1.
2.

P4Merge:Perforce’s companion diff tool.
Other application: Browse to your preferred diff tool.

To specify arguments for third-party diff applications, enter %1 for the name of the first file and %2
for the name of the second file in the Arguments field. Perforce replaces these placeholders with
the actual filenames when calling the diff application.

To assign diff applications by file type:

1

2
3.
4

Click Add.

Select a file extension from the drop-down list.

Enter or browse for the associated application.

Specify arguments for third-party diff applications in the Arguments field:

Enter %1 for the name of the first file and %2 for the name of the second file. The Administration
Tool replaces these placeholders with the actual filenames when calling the diff application.

Click Save.

The extension and associated application are displayed in the list of file type-application
associations.

Applets

You can enable Perforce servers to serve applets that can run in the Administration Tool. In order for
these applets to run in the Administration Tool, you must enable applets in your Administration Tool
preferences. For more information about Perforce applets, see the Perforce Javascript API for Visual
Tools User Guide.

To enable Perforce applets to run in the Administration Tool:

1.
2.

Select Allow Perforce applets to run in P4Admin.

Specify the Perforce servers from which you are willing to accept Perforce applets:
m Enter the Perforce server name or host:port in the Server field.
s Click Add.

3. Click Advanced... to specify the following settings:

m Save cookies from applets(Click Remove Cookies to delete all applet-generated
cookies).

= Allow applets to store data locally

= Manually configure web proxy used by applets for internet access: Enter the web
proxy address and port.
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License statements

Perforce Software includes software developed by the University of California, Berkeley and its
contributors. This product includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit (http://www.openssl.org/).

Perforce Software includes software from the Apache ZooKeeper project, developed by the Apache
Software Foundation and its contributors. (http://zookeeper.apache.org/)

Perforce Software includes software developed by the OpenLDAP Foundation
(http://www.openldap.org/).
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