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About This Manual
This guide tells you how to use P4Admin, the Perforce graphical adminstration tool. It is intended for
anyone using P4Admin to perform basic Perforce Server administrative tasks. Access to the complete
set of administrative tools requires P4, the Perforce Command-line Client.

Helix documentation
The following table lists and describes key documents for Helix users, developers, and administrators.
For complete information see the following:

http://www.perforce.com/documentation

For specific information about… See this documentation…

Overview of Helix version control concepts
and workflows; Helix architecture, and
related products.

Helix Solutions Overview

Administering the Helix versioning engine
to support git repos and LFS files.

Helix for Git

Using the command-line interface to
perform software version management
and codeline management; working with
Helix streams; jobs, reporting, scripting,
and more.

Helix Versioning Engine User Guide

Basic workflows using P4V, the cross-
platform Helix desktop client.

P4V User Guide

Working with personal and shared
servers and understanding the distributed
versioning features of the Helix Versioning
engine.

Using Helix for Distributed Versioning

p4 command line (reference). P4 Command Reference, p4 help

Installing and administering the Helix
versioning engine, including user
management, security settings.

Helix Versioning Engine Administrator Guide:
Fundamentals

Installing and configuring Helix servers
(proxies, replicas, and edge servers) in a
distributed environment.

Helix Versioning Engine Administrator Guide: Multi-site
Deployment

Helix plug-ins and integrations. IDEs: Using IDE Plug-ins
Defect trackers: Defect Tracking Gateway Guide
Others: online help from the Helix menu or web site

http://www.perforce.com/documentation
http://www.perforce.com/perforce/doc.current/manuals/solutions/index.html
http://www.perforce.com/perforce/doc.current/manuals/helix-for-git/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4guide/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4v/index.html
http://www.perforce.com/perforce/doc.current/manuals/dvcs/index.html
http://www.perforce.com/perforce/doc.current/manuals/cmdref/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dist/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dist/index.html
http://www.perforce.com/perforce/r12.1/manuals/p4plugins/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4dtg/index.html
http://www.perforce.com/
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For specific information about… See this documentation…

Developing custom Helix applications
using the Helix C/C++ API.

C/C++ API User Guide

Working with Helix in Ruby, Perl, Python,
and PHP.

APIs for Scripting

Syntax conventions
Helix documentation uses the following syntax conventions to describe command line syntax.

Notation Meaning

literal Monospace font indicates a word or other notation that must be used in
the command exactly as shown.

italics Italics indicate a parameter for which you must supply specific
information. For example, for a serverid parameter, you must supply the id
of the server.

[-f] Square brackets indicate that the enclosed elements are optional. Omit the
brackets when you compose the command.

Elements that are not bracketed are required.

… Ellipses (…) indicate that the preceding element can be repeated as often
as needed.

element1 | element2 A vertical bar ( | ) indicates that either element1 or element2 is required.

Please give us feedback
We are interested in receiving opinions on this manual from our users. In particular, we’d like to hear
from users who have never used Perforce before. Does this guide teach the topic well? Please let us
know what you think; we can be reached at manual@perforce.com.

If you need assistance, or wish to provide feedback about any of our products, contact
support@perforce.com.

http://www.perforce.com/perforce/doc.current/manuals/p4api/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4script/index.html
mailto:manual@perforce.com
mailto:support@perforce.com
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Chapter 1 Administering Perforce Using P4Admin
P4Admin provides a graphical user interface for performing basic Perforce administration tasks. This
chapter discusses the following topics:

• “Home Page” on page 1

• “Server Connections” on page 1

• “Managing Depots” on page 1

• “Managing Users and Groups” on page 2

• “Managing Permissions” on page 3

• “Configuring Administration Tool Preferences” on page 5

To access P4Admin from within P4V, go to Tools > Admininstration.

Home Page
The Administration home page enables users with super and admin permissions to view and use the
following:

• Server information: displays details about the server to which you are connected.

• Disk space usage: displays details about server disk space usage.

• Security level: displays authentication level required by users who access the server.

• Account management shortcuts: displays links to common tasks.

• User licenses: displays details about license count and expiration.

• Inactive users: displays details about users who have not accessed their account in the period of
time you specify.

Server Connections
To administer a server, you must first connect to it as a user that has been granted superuser privilege
for the server. (If your user does not have superuser privilege, you can still administer users and
groups, but cannot manage permissions or define depots.)

To connect to a server, choose Connections > Open Connection…. Specify the desired settings and
click OK. To administer a server, activate the connection by clicking its entry in the Connections pane.
To remove a connection, context-click it and choose Close Connection.

The Administration Tool retains all of the connections that you define, so you do not need to reenter
them the next time you launch the tool.

Managing Depots
If you have super user permission for the Perforce Server instance to which you are connected, you can
manage the depots that it contains. Specifically, you can:
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• Display details about a depot

• Create, edit, or delete depots

• Obliterate files from a depot

Warning Obliterate with extreme caution. Obliteration permanently removes all traces of the
specified files from the Perforce server, including revision records and metadata
(such as references in labels and client workspace specifications). Files in client
workspaces are left untouched, but are no longer recognized as being under
Perforce control.

Managing Users and Groups
All users can display lists of users and groups using the Administration Tool, but only users with
admin or super permissions can make changes. For details about access levels, refer to the Perforce
System Administrator’s Guide.

To view the users defined for the server to which you are connected, choose Tools > Administration
and click the Users & Groups tab.

To display details about a user, click the desired user specification. The details about that user are
displayed at the bottom of the Users tab.

To create a user:

1. Choose Tools > Administration. The Administration Tool is displayed.

2. Choose File > New… > User…

The User dialog is displayed.

3. Enter user information as follows. Click OK after making your entries.

User The Perforce user name.

Password The password (if any) required for the user to
connect to the server.

Email The user’s email address.

Full name The user’s real name.

Job view (Optional) Criteria specifying which jobs
are automatically included on any new
changelists created by the user. Example:
User=bruno Status=open. For details, refer to
the description of the p4 jobs -e flag in the
Perforce Command Reference.

Reviews Files of interest to the user, specified using
depot syntax. When changelists that affect

http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
http://www.perforce.com/perforce/doc.current/manuals/cmdref/p4_jobs.html
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the file are submitted, the user receives email
notification of the change. Note that you can
also specify files of interest by clicking the
Reviews tab.

Groups Groups to which the user belongs. To add the
user to a group, enter the name of the group in
the Group field and click Add, or click Browse,
select the group, and click OK.

To change your password: choose Administration > Change Password….

To display the groups to which a user belongs, expand the user in the Users pane. To display the
users in a group, expand the group in the Groups pane.

To edit a user or group, context-click the user or group you want to edit and choose Edit.

To see the areas of the depot tree to which a user has access, context-click the user, and choose Show
Permissions. The Permissions tab is displayed, with the selected user highlighted.

To add a user to a group, drag the user from the Users pane to the desired group. To remove a user
from a group, context-click the user in the group and choose Remove.

To edit the groups to which a user belongs:

1. Context-click the user and choose Edit User.

The User dialog is displayed.

2. Edit the list displayed in the Group membership field.

Managing Permissions
For details about how permissions work within Perforce, see the Perforce System Administrator’s Guide.

View Permissions

To display the files and folders to which a user has access, click the desired user on the Users tab.

To display the files and folders to which users in a group have access, click the desired group on the
Groups tab.

To display the groups and users that have access to a file or folder, click the file or folder in the
Depot Tree tab.

To see which lines of the protections table control access to a user, group, or area of the depot, click
the user, group or folder of interest. The corresponding line in the protections table is highlighted. (If a
user or group is neither granted nor denied access to a path by means of any entries in the protections
table, the depot path displays "no access" and the "granted to" field is blank.)

To filter out lines in the right-hand pane, use the Access Level sliders to set the lowest and highest
levels. The areas of the depot associated with the highlighted range of access values are displayed.

http://www.perforce.com/perforce/doc.current/manuals/p4sag/index.html
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To see only those permissions that apply to a user’s workstation, enter the IP address of the
workstation in the Host IP filter field. For example, permissions lines with a host value of 92.168.*.*
and 192.168.1.* both apply to a workstation at 192.168.1.10.

To show files in the Depot Tree, click Show files.

Note Virtual streams do not appear in the Depot Tree on the Permissions tab. Virtual
streams map their parent’s paths, and permissions for virtual streams are therefore
always set for the parent’s paths.

Edit the Protections Table

The protections table is displayed in the bottom pane of the screen. It is a representation of the table
used by the p4 protect command, with exclusionary lines shown in red.

To edit the protections table, use the built-in editor or click  to edit the protections table as text.

To deny access to a specific portion of the depot to a user or group, use an exclusionary mapping: place
a dash (-) in front of the path in the Folder/File field. Exclusionary mappings apply to all access levels,
even though only one access level can be selected in the Access Level field.

The following table describes the fields in the protections table.

Access Level The permission being granted. Each permission
level includes all lower-level permissions, except
forreview.

• super- access to all commands and command
options

• admin- permits those administrative
commands and command options that don’t
affect server security

• write- users can submit open files

• open- users can open files for add, edit, delete,
and integrate

• read- users can sync, diff, and print files

• list- users can see names but not contents of
files; users can see all non-file related metadata
(workspaces, users, changelists, jobs, etc.

• review- allows access to the p4 review
command; intended for automated processes,
implies read access.

User/Group Indicates whether this line applies to a Perforce
user or group.
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Name A Perforce user name or group name; can be
wildcarded.

Host The IP address of a client host; can be
wildcarded.

Folder/File The part of the depot to which access is
being granted or denied. To deny access to a
depot path, preface the path with a dash (-).
Exclusionary mappings apply to all access levels,
regardless of the access level specified in the first
field.

Comment Optional description of table entry.

Configuring Administration Tool Preferences
To configure settings for the Administration Tool, choose Edit > Preferences… (Windows) or
P4Admin > Preferences… (Mac). The Preferences dialog includes the following configuration pages:

• “Connections” on page 5

• “Logging” on page 6

• “Display” on page 6

• “Files” on page 6

• “Behavior” on page 7

• “Tools” on page 7

• “Editor” on page 8

• “Diff” on page 8

• “Applets” on page 9

Click Applyto save your changes. Click OKto save your changes and exit the dialog.

Connections
You can configure the following settings for connecting to Perforce servers:

When the application launches:

• Restore all previously opened connections: Do not prompt for connection settings; reconnect to the
server to which you were connected during your last session.

Opening and closing connections:

• Use IP-specific tickets when logging in: Specifies whether your login ticket is restricted to the IP
address from which you are connecting.
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• Automatically log off when closing a connection: Specifies whether your ticket is invalidated when
you log out.

Logging
You can configure the following logging options:

Log pane options:

• Show p4 reporting commands: Specifies whether the log pane in the Administration Tool window
displays all commands issued by the Administration Tool, including commands issued by the
Administration Tool to obtain status information from the Perforce server.

Logging to a file:

• Enable logging to file: Logs Administration Tool activity to the specified file.

• Name: Specifies the name and location of the log file.

• Size: Specifies the maximum size of the log file.

Display
You can configure the following Administration Tool display and localization options:

Application:

• Show the What’s New in P4V page after upgrading:Display the What’s New page as a tab in the
P4V window.

• Dates: Sets the date format used throughout the Administration Tool.

• Use OS format for dates: Use the format that your operating system uses.

• Format dates using Perforce standard (yyyy/mm/dd hh:mm:ss)

Localization:

• Language used for application menus, labels, and dialogs (requires restart): Select language.

• Set encoding for all connections to: Sets the character encoding for connections to unicode-mode
Perforce servers.

If you do not set the encoding here, you are prompted to enter the character encoding every time
you set up a connection to a unicode-mode Perforce server. The encoding that you set here does not
affect server connections whose character encoding has already been set at connection. If you are
unsure which setting to choose, consult your Perforce administrator.

Files
You can configure the way the Administration Tool displays files and file icons:
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• Show Perforce filetype for files in the Workspace and Depot tree:Toggles display of filetype in the
tree panes.

• Show revision information for files in the Workspace and Depot tree:Toggles display of revision
numbers in the tree panes.

• Render thumbnails for Maya files:Enables the Administration Tool to display thumbnail images of
Maya media files.

• File preview font:Specifies the font that the Administration Tool uses to display files in the preview
pane.

Click Show fixed sized fonts onlyto limit the selection in the font drop-down to fixed-sized fonts.

Behavior
You can configure the following Administration Tool user interface behaviors:

Prompts:

• Warn before reverting files: Specifies whether the Administration Tool displays a prompt before
reverting files.

• Prompt for changelist when checking out, adding, or deleting files: Specifies whether the
Administration Tool displays the "Choose changelist" dialog when you open files.

• Prompt to get latest revision when checking out files that are out of date

• Prompt when connecting to a new Perforce Sandbox: Specifies whether the Administration Tool
displays a prompt before you connect to a new Perforce Sandbox.

Drag and drop:

• Enable integration on directory-to-directory drag and drop: Launches the Merge/Integrate dialog
when you drop a folder on another folder.

• Enable diff comparisons on file-to-file drag and drop: Launches the Diff dialog when you drop a
file on another file.

Tools
You can configure the following Revision Graph and Time-Lapse View options:

Revision Graph:

• Use software rendering for Revision Graph: Enable only if your machine is having problems
rendering Revision Graph output. For details, consult the Perforce Knowledge base.

• Limit Revision Graph to ancestors and descendants: Controls how much of a file’s integration
history is displayed.

Time-Lapse View:
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• Show branch history in Time-lapse View by default: Specifies whether Time-lapse View displays
the integration/merge history for the selected file by default. You can also toggle the display of
integration history in Time-lapse View.

Editor
To associate file types with the applications you use to edit them:

1. Click Add.

2. Select a file extension from the drop-down list.

3. Enter or browse for the associated application.

4. (Optional) Select Always use the selected application to open files of this typeto set the
application as the default.

5. Click Save.

You can enter as many applications as you like for each extension. All of the applications will appear
as options when you context-click a file in the Administration Tool and select Open With.

Note Any application that you’ve used to open a file from the context menu in the
Administration Tool appears by default as an associated application on the Editor
page in the Administration Tool Preferences dialog, unless you remove it.

Diff
To set the default diff application, select one of the following:

1. P4Merge: Perforce’s companion diff tool.

2. Other application: Browse to your preferred diff tool.

To specify arguments for third-party diff applications, enter %1 for the name of the first file and %2
for the name of the second file in the Arguments field. Perforce replaces these placeholders with the
actual filenames when calling the diff application.

To assign diff applications by file type:

1. Click Add.

2. Select a file extension from the drop-down list.

3. Enter or browse for the associated application.

4. Specify arguments for third-party diff applications in the Arguments field:

Enter %1 for the name of the first file and %2 for the name of the second file. The Administration
Tool replaces these placeholders with the actual filenames when calling the diff application.

5. Click Save.
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The extension and associated application are displayed in the list of file type-application
associations.

Applets

You can enable Perforce servers to serve applets that can run in the Administration Tool. In order for
these applets to run in the Administration Tool, you must enable applets in your Administration Tool
preferences. For more information about Perforce applets, see the Perforce JavaScript API for Visual Tools
Users Guide.

To enable Perforce applets to run in the Administration Tool:

1. Select Allow Perforce applets to run in P4Admin.

2. Specify the Perforce servers from which you are willing to accept Perforce applets:

• Enter the Perforce server name or host:port in the Server field.

• Click Add.

3. Click Advanced… to specify the following settings:

• Save cookies from applets(Click Remove Cookies to delete all applet-generated cookies).

• Allow applets to store data locally

• Manually configure web proxy used by applets for internet access: Enter the web proxy
address and port.

http://www.perforce.com/perforce/doc.current/manuals/p4jsapi/index.html
http://www.perforce.com/perforce/doc.current/manuals/p4jsapi/index.html
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Appendix  License Statements
Perforce software includes software developed by the University of California, Berkeley and its
contributors. This product includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit (http://www.openssl.org/).

Perforce software includes software from the Apache ZooKeeper project, developed by the Apache
Software Foundation and its contributors. (http://zookeeper.apache.org/)

Perforce software includes software developed by the OpenLDAP Foundation (http://
www.openldap.org/).

http://www.openssl.org/
http://zookeeper.apache.org/
http://www.openldap.org/
http://www.openldap.org/


12 P4Admin User Guide


	P4Admin User Guide
	Table of Contents
	About This Manual
	Helix documentation
	Syntax conventions
	Please give us feedback

	Chapter 1. Administering Perforce Using P4Admin
	Home Page
	Server Connections
	Managing Depots
	Managing Users and Groups
	Managing Permissions
	View Permissions
	Edit the Protections Table

	Configuring Administration Tool Preferences
	Connections
	Logging
	Display
	Files
	Behavior
	Tools
	Editor
	Diff
	Applets



	License Statements

